Windows client is not ending cleanly

General Clan Lord discussion

Moderator: CL GMs

Post Reply
User avatar
Icy
Noble
Posts: 1005
Joined: Mon Jan 03, 2005 7:14 pm
Profession: All
Race: Dwarf
Player Status: Inactive

Windows client is not ending cleanly

Post by Icy » Thu May 25, 2017 8:01 pm

Hoping the client GM can see this...noticing that the Windows client is not ending in Windows 10 Pro Version 1703 (Creators update). I've stopped the client by clicking the X in the top right to close it an hour ago and still see it running as a background process. Please take a look....this is the second machine ive noticed this on. Same Windows version for the other machine.
Image
3/3/15 9:27:45a Icy has fallen to a Rat.

User avatar
Borzon
Arilon Legacy
Arilon Legacy
Posts: 660
Joined: Sat Aug 28, 2010 5:29 am
Profession: Bloodmage
Race: Sylvan
Player Status: Inactive

Re: Windows client is not ending cleanly

Post by Borzon » Fri May 26, 2017 12:08 pm

Ive noticed this as well, also cannot open the client again when it's still running in the background.

User avatar
Icy
Noble
Posts: 1005
Joined: Mon Jan 03, 2005 7:14 pm
Profession: All
Race: Dwarf
Player Status: Inactive

Re: Windows client is not ending cleanly

Post by Icy » Mon Jun 05, 2017 12:24 pm

Still exists in v1018 build 2017-05-30.1
3/3/15 9:27:45a Icy has fallen to a Rat.

User avatar
Icy
Noble
Posts: 1005
Joined: Mon Jan 03, 2005 7:14 pm
Profession: All
Race: Dwarf
Player Status: Inactive

Re: Windows client is not ending cleanly

Post by Icy » Wed Jun 21, 2017 8:32 pm

Still occurring in v1021-2017-06-18.1.dll
3/3/15 9:27:45a Icy has fallen to a Rat.

User avatar
Daimoth
Llehn ryn Rhav'tsath
Posts: 6310
Joined: Sun Apr 06, 2003 1:29 pm
Profession: Destroyer of Worlds
Race: Fen'neko
Player Status: Active
Contact:

Re: Windows client is not ending cleanly

Post by Daimoth » Thu Jun 22, 2017 4:45 am

nice humblebrag with the bandwidth, PIRATE.

But yeah, this is happening to me too
Extreme level disparity is community disparity.

User avatar
Icy
Noble
Posts: 1005
Joined: Mon Jan 03, 2005 7:14 pm
Profession: All
Race: Dwarf
Player Status: Inactive

Re: Windows client is not ending cleanly

Post by Icy » Mon Jun 26, 2017 11:16 am

Daimoth wrote:nice humblebrag with the bandwidth, PIRATE.

But yeah, this is happening to me too
Just some linux distros man :oops:
3/3/15 9:27:45a Icy has fallen to a Rat.

Org du Lac
Exile
Posts: 425
Joined: Sat May 20, 2006 4:18 pm
Contact:

Re: Windows client is not ending cleanly

Post by Org du Lac » Thu Jun 29, 2017 12:17 pm

80 MB/s? :o the fastest even possible to get here is 13 MB/s, and I'm in a major city with fiber.

Unless you're running torrents at your workplace, in which case I hope for your job's sake that those are actually Linux distros (and even then...)

User avatar
Icy
Noble
Posts: 1005
Joined: Mon Jan 03, 2005 7:14 pm
Profession: All
Race: Dwarf
Player Status: Inactive

Re: Windows client is not ending cleanly

Post by Icy » Sat Jul 15, 2017 4:30 am

New one same problem. Running it in compatibility mode for Windows 7 and seeing it occur less.
3/3/15 9:27:45a Icy has fallen to a Rat.

User avatar
Icy
Noble
Posts: 1005
Joined: Mon Jan 03, 2005 7:14 pm
Profession: All
Race: Dwarf
Player Status: Inactive

Re: Windows client is not ending cleanly

Post by Icy » Wed Aug 16, 2017 8:00 am

This is still occurring in the latest version.
3/3/15 9:27:45a Icy has fallen to a Rat.

User avatar
Borzon
Arilon Legacy
Arilon Legacy
Posts: 660
Joined: Sat Aug 28, 2010 5:29 am
Profession: Bloodmage
Race: Sylvan
Player Status: Inactive

Re: Windows client is not ending cleanly

Post by Borzon » Mon Oct 02, 2017 11:40 am

I think I found a fix, I had a problem with CL not launching due to "Invalid XML file, missing or multiple root tags".

I found a fix online for this that said to locate the application (ClanLord.exe in this case) in the commandprompt and use the command /ResetNavPane

This fixed the error for me and afterwards I didn't notice CL running in the background anymore.

That or it got fixed with an update, I dunno.

User avatar
Icy
Noble
Posts: 1005
Joined: Mon Jan 03, 2005 7:14 pm
Profession: All
Race: Dwarf
Player Status: Inactive

Re: Windows client is not ending cleanly

Post by Icy » Tue Nov 14, 2017 5:30 am

Ill give that a shot but I can assure you still broken for all my clients I just stopped reporting it.
3/3/15 9:27:45a Icy has fallen to a Rat.

Post Reply