Fix the update process... it's pretty buggy

Polls, discussion and commentary on suggested issues.

Moderators: Lorikeet, CL GMs

Post Reply
Sonny_Bill
Exile
Posts: 176
Joined: Tue Sep 09, 2014 3:04 am
Profession: Fighter
Race: Sylvan
Player Status: Active

Fix the update process... it's pretty buggy

Post by Sonny_Bill » Thu Nov 26, 2015 10:21 pm

I think that the devs should fix the process of updating CL (or re-think it). Right now when an update is pushed out, here's what happens...

1) I get notified that an update is there when I try to login... a new version is downloaded, the app quits and then the app re-opens.
2) When the app re-opens I can't do anything (all the menus are grey), so I have to quit it.
3) When I re-open the app and try to login, the 'second part' of the update has to download. Once it has downloaded, I try to login and despite it being correct, the app will say 'your password is wrong'.
4) I quit the app and re-open it... now I can play the game.

Is this something the devs have thought about and put in the 'too hard, it's annoying but we wanna improve the game instead' basket, or is it something that only happens on some computers, which they may not be aware of?

Mac
Exile
Posts: 266
Joined: Thu Jun 16, 2005 12:05 pm
Profession: PWC Salandra
Race: Ghorak Zo
Player Status: Active
Contact:

Re: Fix the update process... it's pretty buggy

Post by Mac » Fri Nov 27, 2015 2:21 am

You should probably include some details about your computer like operating system, version, etc. I've never had any problems like you're describing.

Edit: Win7 x64 (fully updated)
Last edited by Mac on Mon Nov 30, 2015 6:39 am, edited 1 time in total.

Sonny_Bill
Exile
Posts: 176
Joined: Tue Sep 09, 2014 3:04 am
Profession: Fighter
Race: Sylvan
Player Status: Active

Re: Fix the update process... it's pretty buggy

Post by Sonny_Bill » Fri Nov 27, 2015 4:23 am

Mac wrote:You should probably include some details about your computer like operating system, version, etc. I've never had any problems like you're describing.
Interesting... it's an i7 MacBook Pro running OS X 10.11.1. Are you using the Windows version?

Sala Dragon
Exile
Posts: 493
Joined: Mon Mar 21, 2005 3:13 pm
Contact:

Re: Fix the update process... it's pretty buggy

Post by Sala Dragon » Fri Nov 27, 2015 4:56 am

I also feel like something changed recently... because the update process is working way better for me. For the first time in like 8 years, when I download the new application, it actually restarts automatically and starts the images and sounds update process. rMB 10.11.

User avatar
Lorikeet
Pogue Mahone
Pogue Mahone
Posts: 3714
Joined: Sat Apr 05, 2003 12:58 pm
Profession: Healer
Race: Fen'neko
Player Status: Active
Contact:

Re: Fix the update process... it's pretty buggy

Post by Lorikeet » Fri Nov 27, 2015 7:11 am

Hmm. I'm in between the two of you (Mac on OS 10.6.8--yeah, when I get an operating system I like, I stick with it!) Mine just autodownloads once and closes and I have to open it again and it autodownloads the second time and that's it.

User avatar
thesquib
Exile
Posts: 112
Joined: Tue Apr 03, 2007 2:02 am
Profession: Fighter
Race: Dwarf
Player Status: Active

Re: Fix the update process... it's pretty buggy

Post by thesquib » Fri Nov 27, 2015 1:16 pm

I have the same process are Lori. The update downloads, Clan Lord quits, and then I have to go and open it again manually for the next stage. This is on 10.10.5 (14F27)
HWC Ruuk

User avatar
Maeght
Trainer
Posts: 5797
Joined: Sat Apr 12, 2003 2:05 pm
Profession: Ranger
Race: Halfling
Player Status: Active
Location: University of Puddleby
Contact:

Re: Fix the update process... it's pretty buggy

Post by Maeght » Fri Nov 27, 2015 6:32 pm

Ditto for me. 10.10.5.

Sonny_Bill
Exile
Posts: 176
Joined: Tue Sep 09, 2014 3:04 am
Profession: Fighter
Race: Sylvan
Player Status: Active

Re: Fix the update process... it's pretty buggy

Post by Sonny_Bill » Fri Nov 27, 2015 8:29 pm

thesquib wrote:I have the same process are Lori. The update downloads, Clan Lord quits, and then I have to go and open it again manually for the next stage. This is on 10.10.5 (14F27)
Hmmmm... sounds like it's just me then :(

Wonder what I'm doing wrong.

User avatar
Destian
Trainer
Posts: 1941
Joined: Fri Jun 11, 2004 10:51 am
Profession: Healer/Slug Wrangler
Race: Human
Player Status: Spambot

Re: Fix the update process... it's pretty buggy

Post by Destian » Sat Nov 28, 2015 10:11 pm

Lorikeet wrote:Hmm. I'm in between the two of you (Mac on OS 10.6.8--yeah, when I get an operating system I like, I stick with it!) Mine just autodownloads once and closes and I have to open it again and it autodownloads the second time and that's it.
Me too.

And you're entirely right to stay with 10.6.8. It's the last fast, stable OSX version that I'm aware of. I tried El_Capitain for like a day and it was so bad I reverted to 10.6.8...
A video guide to healer pets: http://www.youtube.com/watch?v=I6ejD_9X1io
"Solomon chuckles"

Sonny_Bill
Exile
Posts: 176
Joined: Tue Sep 09, 2014 3:04 am
Profession: Fighter
Race: Sylvan
Player Status: Active

Re: Fix the update process... it's pretty buggy

Post by Sonny_Bill » Sun Nov 29, 2015 8:39 pm

Destian wrote:
Lorikeet wrote:Hmm. I'm in between the two of you (Mac on OS 10.6.8--yeah, when I get an operating system I like, I stick with it!) Mine just autodownloads once and closes and I have to open it again and it autodownloads the second time and that's it.
Me too.

And you're entirely right to stay with 10.6.8. It's the last fast, stable OSX version that I'm aware of. I tried El_Capitain for like a day and it was so bad I reverted to 10.6.8...
Yeah I dunno why I keep upgrading. Each version seems to take away or hide a feature I like, and try to market a new feature to me (or some consumer app that will 'make my life easier'). Things like hiding the Library folder, disabling Dashboard by default (that's where I record all my ranks, on a sticky note), forcing all apps to be signed (unless you allow all apps manually), totally changing the (former) 'iApps' GUI every release and having what... Mac.com, Mobile Me, iCloud...etc.

Grumble grumble... I want the old Apple back. IMO thr golden days were ~2000 when I had my G4 Cube. Perfect machine because I could upgrade the HD, RAM, graphics card and CPU (despite it being compact). Also, OS X was far more 'clean' I felt. Thems were the days.

Yeah for those who haven't realised... I'm a bit of a whinger :)

Sala Dragon
Exile
Posts: 493
Joined: Mon Mar 21, 2005 3:13 pm
Contact:

Re: Fix the update process... it's pretty buggy

Post by Sala Dragon » Mon Dec 07, 2015 8:45 am

IMO 10.6.8 is still the best too... but have to stay relatively more updated for work-related reasons! Quite a few things, like Microsoft Remote Desktop, don't work anymore on 10.6.8. At least Clan Lord still does ;)

Really though it's nice that I don't have to reopen the app to resume the update process. I wonder if it's El Capitain related or if something changed in the client.

User avatar
Elenis
Exile
Posts: 67
Joined: Wed Mar 09, 2005 8:32 am
Profession: Ranger
Race: Human
Player Status: Active
Location: Travelling the road unseen.
Contact:

Re: Fix the update process... it's pretty buggy

Post by Elenis » Sat Dec 12, 2015 10:28 pm

Since the most recent update I've been unable to launch CL on either Win7 or Win8.1. Either from updates or from full client downloads. I am a sad, sad panda.

User avatar
Maeght
Trainer
Posts: 5797
Joined: Sat Apr 12, 2003 2:05 pm
Profession: Ranger
Race: Halfling
Player Status: Active
Location: University of Puddleby
Contact:

Re: Fix the update process... it's pretty buggy

Post by Maeght » Sun Dec 13, 2015 2:18 pm

I never play on my Windows machine, but I downloaded the full client, unzipped to my desktop, launched, logged into the character manager and tried logging in with a character. I forgot the character password, but the app launches and seems to be working.

The most common issue I've noticed is anti-virus software tagging CL DLL's and quarantining them.

Sonny_Bill
Exile
Posts: 176
Joined: Tue Sep 09, 2014 3:04 am
Profession: Fighter
Race: Sylvan
Player Status: Active

Re: Fix the update process... it's pretty buggy

Post by Sonny_Bill » Sat Dec 19, 2015 12:22 pm

FWIW the latest update worked perfectly. No mention of it in the news (and most said it worked before) so I guess my computer just sorted itself out between updates. Either way, excellent news for me - the update process had never worked properly for me before this. Merry bawkmas!

Post Reply